30 авг. 2011 г.

Устранение ошибок типа "Strict Standards:..." в связке xampp+joomla 1.7

Сегодня столкнулся с такой вот проблемкой.
Решил я, значит, поковыряться в Джумле, потренироваться создавать сайтики. Чтобы сильно не морочить себе голову, скачал набор XAMPP (инсталлер под винду), где уже есть APAche, PHP, MySQL плюс куча телз для них и всё это настроено так, чтобы друг с другом работало "из коробки". Залил в апач джумлу, зашел в джумлу в браузере, прошел е веб-инсталляцию и тут - хопа, на пол-страницы ошибки типа  "Strict Standards:..." и еще куча матюков :) Что делать?...
Вскоре решение было найдено: необходимо было зайти в директорию php, там есть файлик php.ini и в нем найти и изменить параметр error_reporting  на:

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

и  display_errors  на:

display_errors = Off

Далее перезапускаем апач - и всё, всё работает без проблем и матюков :)